Operation Manual for Configuration and Evaluation Software DR-USB-VS
# Contents

1. Contents................................................................................................................................. 2

2. Imprint......................................................................................................................................... 3

3. Remarks....................................................................................................................................... 4
   3.1 License Terms for Lorenz Software......................................................................................... 4
   3.2 Intended Use .......................................................................................................................... 4
   3.3 Designation of the Remarks..................................................................................................... 4
   3.4 System Requirements ............................................................................................................ 4
   3.5 Installation ............................................................................................................................. 5
       3.5.1 Introductory Steps before the Installation ........................................................................ 5
       3.5.2 Connection of USB Devices to a PC ................................................................................ 5
       3.5.3 Check-up .......................................................................................................................... 6
       3.5.4 Debugging at driver installation ....................................................................................... 6

4. Preamble....................................................................................................................................... 7
   4.1 Product Description ............................................................................................................... 7
   4.2 Setup of the Software ............................................................................................................ 7
   4.3 Safe and Correct Use ............................................................................................................. 7

5. Starting the Software .................................................................................................................. 7

6. Description of the Operating Mode ............................................................................................. 8
   6.1 The Menu Bar/Navigation Bar of the Program ...................................................................... 8
       6.1.1 File  Save Measvalue (Shortcut ‘Ctrl+M’) .................................................................... 8
       6.1.2 File  Save Diagram (Shortcut ‘Ctrl+D’) ..................................................................... 9
       6.1.3 File  Print (Shortcut ‘Ctrl+P’) .................................................................................. 10
       6.1.4 File  Exit (Shortcut ‘Ctrl+E’) .................................................................................. 10
       6.1.5 Operating Mode ........................................................................................................... 10
       6.1.6 View .............................................................................................................................. 11
       6.1.7 Language ...................................................................................................................... 11
       6.1.8 Help  Info ...................................................................................................................... 11
       6.1.9 Help  Advice ................................................................................................................. 11
   6.2 Configuration Mode ............................................................................................................... 12
       6.2.1 Sensor Connection ......................................................................................................... 12
           6.2.1.1 Sensor Connection  Baud Rate ........................................................................... 13
           6.2.1.2 Sensor Connection  Update .............................................................................. 13
       6.2.2 Sensor Information ......................................................................................................... 14
           6.2.2.1 Sensor Information  Common ............................................................................ 14
           6.2.2.2 Sensor Information  Channels ............................................................................ 15
   6.2.3 Measurement Adjust .......................................................................................................... 15
       6.2.3.1 Measurement Adjustments  Measured Variable  Type ........................................... 16
       6.2.3.2 Measure Adjust.  Measured Variable  Sample Rate ............................................... 16
       6.2.3.3 Measure Adjust.  Measured Variable  Display ......................................................... 16
       6.2.3.4 Measure Adjust.  Diagram ....................................................................................... 16
       6.2.3.5 Measure Adjust.  Trigger ......................................................................................... 18
           6.2.3.5.1 Triggering to a Physical Variable ( M, u, n, P ) .............................................. 20
           6.2.3.5.2 Diagram Example ......................................................................................... 20
           6.2.3.5.3 Calculation of Hysteresis .............................................................................. 20
       6.2.3.6 Measurement Adjustments  OK/NOK Evaluation ............................................... 21
   6.2.4 Documentation ................................................................................................................... 22
       6.2.4.1 Documentation  Output Measured Values ............................................................... 23
       6.2.4.2 Documentation  Output diagram ............................................................................. 23
       6.2.4.3 Common Settings Output Values and Output OK/NOK-Evaluation .................. 24
       6.2.4.4 Documentation  Additional information ................................................................. 24
   6.2.5 Sensor Adjustment ............................................................................................................. 25
   6.3 Meas./Diagram Mode ........................................................................................................... 26
7 Parameter sets ........................................................................................................................................... 28
  7.1 Save Parameter set ................................................................................................................................ 28
  7.2 Use Parameter set .................................................................................................................................... 28
  7.3 Delete Parameter set ............................................................................................................................... 28
  7.4 Export all Parameter sets ...................................................................................................................... 28
  7.5 Import all Parameter sets ...................................................................................................................... 29

8 User Data.......................................................................................................................................................... 29

9 Debugging ...................................................................................................................................................... 30

10 Continuative Documents .......................................................................................................................... 30

2 Imprint

<table>
<thead>
<tr>
<th>Manufacturer, Place</th>
<th>Lorenz Messtechnik GmbH, D-73553 Alfdorf.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Valid for...</td>
<td>DR-USB-VS starting from Version 2.03</td>
</tr>
<tr>
<td>Copyright</td>
<td>© 2008-2016 Lorenz Messtechnik GmbH, Alfdorf.</td>
</tr>
<tr>
<td>Reprint-Interdiction</td>
<td>Reprint, even in extracts, only with written authorization from Lorenz Messtechnik GmbH.</td>
</tr>
<tr>
<td>Modification</td>
<td>Technical changes reserved.</td>
</tr>
</tbody>
</table>

Windows®, Excel® are either registered trademarks or registered brands and brands of the Microsoft Corp. (according to the State Law of Washington), Redmond, Wash., US and/or other countries.

All trademarks or brands used in this document refer only to the respective product or the holder of the trademark or brand. Lorenz Messtechnik GmbH does not raise claims to other than its own trademarks or brands.
3 Remarks
This manual describes installation procedures with Windows Vista. The installation procedures with Windows 7, 8, 8.1 and 10 are similar.

Please note that Windows needs local administrative rights to install drivers. Please ask your administrator, if you do not have these rights.

3.1 License Terms for Lorenz Software
The copyrights for this software remain at:

Lorenz Messtechnik GmbH
Obere Schlossstrasse 131
73553 Alfdorf

Germany
http://www.lorenz-sensors.com

During the software installation, the license conditions will be displayed and must be accepted, otherwise the installation will be aborted. After the installation, the license conditions can be viewed in menu ‘Help → Advice’.

3.2 Intended Use
The DR-USB-VS software was designed for the adjustment, control and read-out of a sensor from the DR3000-series.
Further functions of sensors from the DR3000-series are reception, display and storing of measured values. Any use beyond this is considered as not intended.

3.3 Designation of the Remarks
If possible remaining dangers emerge during the operation with DR-USB-VS, this will be indicated by the following symbols in this operation manual:

Note:
Important points to consider

3.4 System Requirements
The operation of DR-USB-VS requires a PC with following systems:
- Windows Vista, Windows 7, 8, 8.1 or Windows 10.
- USB-Interface for the connection of the torque sensor
- Maximum two monitors will be supported

Recommended Hardware Requirements:
- Application process without diagram Single-Core from 2,0 GHz
- Application process with diagram Dual-Core from 1,8 GHz
- The higher the measuring rate and the longer a measurement lasts, the higher the required main storage. The measurement ends as soon as the system does not provide any more free main storage space.
3.5 Installation

The Setup “Setup_DR-USB-VS.msi” includes the executable file DR-USB-VS.exe, the driver package for the USB connection, manuals for DR-3000 and the software DR-USB-VS. During the setup program the desired additional shortcuts to be installed can be selected first. Then, the installation directory must be chosen and it must be decided who will use the application on the PC. After finishing the installation process the USB drivers should be installed.

Please close all programs and back up your data before the installation. All other applications, especially the virus scanner and the security software, should be closed as well.

3.5.1 Introductory Steps before the Installation

- Disconnect all Lorenz USB devices from your PC.
- Sign up on your PC with administration permissions.
- Remove possibly existing Lorenz USB sensor drivers under System Control → Programs/Software by uninstalling the program.
- Run the downloaded file „Setup_DR-USB-VS.msi“.
- Follow the instructions.
- Start the USB Driver install program within the newly installed program folder, if necessary¹.

The signature is a confirmation, implemented by Microsoft, stating that the driver package is originally made by Lorenz Messtechnik GmbH.

The Lorenz Messtechnik GmbH driver package is deduced from a driver package signed by Microsoft, whereby only some character strings and the identification features of the Lorenz USB Sensor Interfaces were adapted.

3.5.2 Connection of USB Devices to a PC¹

Now, the driver installation can be closed. Connect the USB device to the PC (you must possibly confirm the message depending on the operating system). Now the red marked entry below must be found in the device manager.

The initial connection requires administrator rights.

¹ For the sensors to the RS485 port, the driver installation is not necessary. If you do not install the driver, skip the paragraphs 3.5.2 - 3.5.4.
3.5.3 Check-up

The correct installation can be checked in the device manager:

Open the device manager
- Through System control → System → Device Manager
- Alternatively by the Windows key + Pause → Hardware → Device Manager
- Alternatively Start → Execute → devmgmt.msc

If the display shows “Lorenz USB sensor interface Port (COM#)” when a Lorenz USB device is connected, the driver package was installed correctly. Under this COM Port, the software can communicate with the device. If several Lorenz Interface devices are connected a separate line for each device will be indicated in the device manager.

![Device Manager](image)

3.5.4 Debugging at driver installation

This chart helps to find frequent errors and the measures for debugging.

<table>
<thead>
<tr>
<th>Error</th>
<th>Possible Cause</th>
<th>Debugging</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device is pointed out under “?” or “Other devices → Unknown Device/USB Device”</td>
<td>Driver not installed.</td>
<td>Disconnect the device from the PC. Install driver package. The initial installation must occur with administrator rights. Connect the device to the PC.</td>
</tr>
<tr>
<td>Driver installation is aborted with errors.</td>
<td>Missing administrator rights.</td>
<td>Repeat the procedure with administrator rights.</td>
</tr>
<tr>
<td>Driver installation fails when connecting.</td>
<td>Missing administrator rights.</td>
<td>Repeat the procedure with administrator rights.</td>
</tr>
</tbody>
</table>
4 Preamble

4.1 Product Description

This operation manual describes characteristics and operation courses of the DR-USB-VS.

4.2 Setup of the Software

The DR-USB-VS consists of following components:
- Configuration possibilities for the VS2
- Storage of sensor-related scaling and adjustment data
- Display for the presentation of measured data (actual value, tare value, minimal value and maximal value)
- Display and storage of measured data evaluations
- Presentation of the measured data in a diagram
- Storage of measured data in CSV-format (output configurable)
- Storage of the diagram in BMP-format (output size configurable)
- Print-out of the diagram (output size defined)
- Presentation of the sensor information

4.3 Safe and Correct Use

Pay attention to the correct sensor adjustment.
Pay attention to the correct DR-USB-VS configuration.
Choose a significant file identification/prefix when storing measured data.

5 Starting the Software

The software starts only if it identifies a compatible sensor at the USB or RS485 connection. After starting the executable file, the search for a compatible sensor is displayed. If the search is unsuccessful, check whether the USB or RS485 circuit at the sensor is connected to the PC and whether the USB drivers have been installed (if you are working with USB Sensor). Then click on ‘Search again’ to restart the search for a compatible sensor. If a compatible sensor was found, the sensor-related data will be read-out automatically. If you want to work with USB sensors only, the search can be accelerated. Use the Checkbox „USB only“ for this. This setting can be changed here and in Dialog “Sensor Connection” at any time.

![Software start screen](image1)
![Search again screen](image2)
6 Description of the Operating Mode

The software consists of a menu bar, navigation bar, status bar and a workspace. The functions of the menu bar comply with the navigation bar. The digital measured value displays of the physical values and the diagram can be seen under ‘Operating Mode → Meas./Diagram Mode’. In the workspace the consolidated dialogs are displayed under ‘Operating Mode’.

- **Adjust. Mode** (see chapter 6.2)
- **Meas./Diagram Mode** (see chapter 6.3)

Switching between the dialog boxes can be done through the navigation bar as well as through the equated menu bar. Adjustment changes in the dialog box will be accepted without confirmation. All adjustments are stored when ending the application and will be loaded when the application gets restarted.

The status bar displays current status information of the application

- ‘Ready for use. Sensor connected’
- ‘Sensor disconnected’
- ‘Measure...’
- ‘wait for trigger start event’
- ‘Measure! Wait for trigger stop event’

Furthermore, information from the menu bar and navigation bar through the control elements as well as the storage progress in a CSV-file are indicated in the status bar.

6.1 The Menu Bar/Navigation Bar of the Program

6.1.1 File → Save Measvalue (Shortcut ‘Ctrl+M’)

From here, the measured data of the last measurement² are stored in a CSV-file. The output format of the file is adjustable in dialog box ‘Operating Mode → Adjust. Mode → Documentation’ under the headline ‘Output measured values’ (see chapter 6.2.4.1 Documentation → Output Measured Values). In the first column of the CSV-file, the measured values are numbered ascending. The output of columns two to maximum four will be taken over by adjustment ‘Operating Mode → Adjust. Mode → Measure Adjust.’ under the ‘Diagram’ headline. Here, each adjusted physical value will be written into the file. The sequence: [X-Axis], [Y1-Axis], [Y2-Axis], [Y3-Axis].

**Caution:** all output adjustments must be carried out before the measurement.

**Caution:** a CSV-file is a text file for the storage of simple structured data. The abbreviation CSV stands for Character Separated Values or Comma Separated Values. These values are separated from each other by special delimiters, e.g. by comma, semicolon. A CSV-file can be started by double-click in Excel®. The denotation of list/field/line-ending marks are not explicitly determined. The definitions under 6.2.4.1 Documentation → Output Measured Values → ‘End of line character’ / 'Column separator' / 'Decimal separator' must optionally be adjusted in DR-USB-VS or in your spreadsheet. For this, see the manual for your spreadsheet.

---

² Measurement: recording of a measured value series in the configured measuring rate of Start[...] to Stop [...].
6.1.2  File → Save Diagram (Shortcut ‘Ctrl+D’)

From here, measured data of the previous measurement can be stored in a BMP-file. Predefined output variables can be adjusted in ‘Operating Mode → Adjust. Mode → Documentation’ under the ‘Output diagram’ headline in box ‘Memory size’. There are following possibilities:

- **max:**
  Adjustment is only available, if the running system recognizes two monitors. On these two monitors, the diagram is maximum size stretched and stored.

- **normal:**
  The diagram is stretched to approx. screen size and stored.

- **min:**
  The diagram is stretched to approx. 800x600 pixel of the monitor and stored.

- **Window:**
  The diagram gets stored the same way as it was adjusted by the user.

Any measurement range can be selected by the range slider and the interval slider.

The diagram has a context menu. By right-click on the mouse key, following functions are available:

- **Zoom in:**
  The mouse pointer becomes cross-shaped. By pressing the left mouse key and moving the mouse in the diagram, a rectangle appears which can be zoomed by releasing the mouse key.

- **Zoom out:**
  The diagram indicates the complete range of the previous measurement.

- **Scrolling:**
  The mouse pointer becomes cross-shaped with arrows. By holding the left mouse key in the diagram, the curve can be shifted.

- **Grid on/off:**
  The stroke lines in the diagram form the raster. By this function, the stroke lines can be faded in/out.

- **Show Legend:**
  The legend indicates the physical variables and their units. With this function it can be faded in/out.

**Caution:** When storing the diagram, only the current illustrated part of the measurement will be stored.
6.1.3 File → Print (Shortcut ‘Ctrl+P’)

This function enables the print-out of the diagram with print time, configurable heading, configurable remark, configurable address as well as a customized logo (picture to the right). The user can carry out the configuration by the navigation bar “documentation”. Line breaks in remark and address are converted into blanks.

Following restrictions are valid

- The heading is restricted to 20 characters
- The remark is restricted to 57 characters
- The address is restricted to 82 characters

In order to contain a customized logo, it must be stored under the file name “Custom_Print_Logo.bmp” and copied to the folder “%USERPROFILE%\AppData\Local\Lorenz”.

Caution: the recommended properties of the “BitMap „Custom_Print_Logo.bmp“ are:

- Resolution: 160 pixel *160 pixel
- Maximum bit depth: 32bit

If there is no file named “Custom_Print_Logo.bmp” placed in the folder “%USERPROFILE%\AppData\Local\Lorenz“, the Lorenz logo will be contained.

6.1.4 File → Exit (Shortcut ‘Ctrl+E’)

Terminates the program. If the program is still in the measuring mode while terminating, the measurement will be ended. If automatic storage is adjusted (see chapter 6.2.4.1 Documentation → Output Measured Values and chapter 6.2.4.2 Documentation → Output diagram) it will be executed before the program is terminated.

6.1.5 Operating Mode

This umbrella term contains all sensor-specific adjustments ‘Adjust. Mode’ as well as the ‘Meas./Diagram Mode’. By selecting a mode it will be displayed in the workspace. Following dialog boxes can be displayed:

- Adjust. Mode → Sensor Connection (see chapter 6.2.1)
- Adjust. Mode → Sensor Information (see chapter 6.2.1.2)
- Adjust. Mode → Measure Adjust. (see chapter 6.2.2.2)
- Adjust. Mode → Documentation (see chapter 6.2.3.6)
- Adjust. Mode → Sensor Adjustment (see chapter 6.2.5)
- Meas./Diagram Mode (see chapter 6.3)

When restarting the software it will start with the previous active dialog box. The next menu can be entered via the shortcut ‘Ctrl+TAB’; the previous menu can be entered by ‘Ctrl+Shift+TAB’

---

3 The environment variable %USERPROFILE% stores the current Windows® path of the registered user.
This path is defined during the Windows® installation and can be changed in the system control and through the group guidelines.
The user name is also included in the path...
As default, this path under Windows® 7 reads: C:\Users\<Username>
6.1.6 View

The control elements under ‘View’ are responsible for fade in/out of bars and displays as well as setting back the windows view. In the menu/navigation bar a checkmark indicates faded in/out bars and displays. The digital displays and the diagram can only be switched in the measuring and diagram mode, otherwise they are grey (disabled). While executing ‘View → Reset Views’ (e. g. via the shortcut ‘Ctrl+R’) the digital displays, the diagram and the main window are set back to original condition.

6.1.7 Language

Here, the language of the DR-USB-VS can be adjusted. All indications of the application are changed in accordance with the selected language. Following languages are supported:

- German
- English
- French

At restart of the software, the previous adjusted language will remain.

6.1.8 Help → Info

Here, the version number of the software is indicated.

6.1.9 Help → Advice

Contains the license conditions for this software, the address as well as Website and E-mail links.
6.2 Configuration Mode

The configuration mode contains all sensor-, measurement- and documentation adjustments as well as the output of sensor information. The adjustment dialog boxes are shown in the operation range through the menu/navigation bar. In the following chapters, the adjustments are introduced and the functions are explained.

6.2.1 Sensor Connection

This software only supports Lorenz USB/Rs485 sensors with integrated quadrature encoder resp. integrated speed/angle measurement (e.g. DR-3000/29xx-series) If a Lorenz USB sensor is connected with a PC, it will be automatically activated by the DR-USB-VS.

The DR-USB-VS can only activate one sensor at a time. The selected sensor gets activated by double-click in one of the displayed lines where the ‘State’ is shown as ‘available’.

Sensors in columns with ‘State’ ‘not available’ cannot be activated. The State ‘not available’ means that the DR-USB-VS could not open or activate the interface, or that the sensor did not respond. If another process or application takes access on the desired interface, this access should be terminated.

Search for free interfaces by the ‘Update’ key.

Status ‘not supported’ indicates incompatible Lorenz sensors.

The list gives further sensor information such as baud rate, serial number, final value of measuring range and stator type.

The deactivation of a sensor occurs either by the activation of another sensor or by double-clicks on the active sensor. When deactivating, the COM interface gets released and can be used by other applications.
6.2.1.1 Sensor Connection → Baud Rate

You can change the baud rate with a simple click in the column Baud rate on the corresponding line of the Interface (see example left: ‘Interface’ „PCI Communications Port [COM 22]“) between 115200, 230400 and 921600 Baud rate.

<table>
<thead>
<tr>
<th>Baud Rate in Baud</th>
<th>Maximum Adjustable Measure Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>115200</td>
<td>2500/s</td>
</tr>
<tr>
<td>230400</td>
<td>5000/s</td>
</tr>
<tr>
<td>921600</td>
<td>20000/s</td>
</tr>
</tbody>
</table>

The changed baud rate will be permanently stored in the Sensor. This adjustment apply to the interaction with other applications.

The maximum adjustable Measure rate depends of the selected baud rate and the used processor of the PC.

Each sensor does not support all available baud rates. The software supports you to get a baud rate the sensor supports.

6.2.1.2 Sensor Connection → Update

During this update (i.e. after you click on the button "Update", but also after connecting or disconnecting a USB connection or with the change of the baud rate) all compatible interfaces (or predefined subset of them) which are registered in the PC will be checked and read-out. A subset can be defined using the check boxes "USB Only" or "Only previously available". Please use these restrictions if desired for accelerating the search. In the case of connecting or disconnecting a USB port, the setting "Only previously available" will be ignored.

Here, the baud rate is detected and automatically adjusted. Furthermore the complete sensor data and sensor information will be read-out. The course of the update will be visually presented (see image).

Caution: The state of SI-RS485 devices must be updated manually with the button “Update”
6.2.2 Sensor Information

This dialog box shows information and characteristics of the activated sensor. The DR-USB-VS reads the data during the sensor activation. If no sensor is activated, all indications are 'n.a.' (not available). If the uncertainty of measurement shows 'n.a.' it means that the uncertainty of measurement is not stored in the activated sensor. This value is determined in % from a Lorenz proprietary calibration or a DKD calibration. The detected value can be stored in the active sensor in menu ‘Sensor Adjustment’ under ‘Store uncertainty of measurement in the sensor’.

Lorenz sensors have two storage spaces for adjustment values, an unchangeable proprietary block and a changeable user adjustment block. If a user adjustment has been accomplished successfully in menu sensor adjustment, this adjustment is active in the sensor and indicated ‘active’ in the sensor information with creation date. The factory adjustment is deactivated by this. (Further information can be found in chapter 6.2.5 Sensor Adjustment)

At user adjustment, the condition ‘active’ is also marked with ‘*’, in case this adjustment uses the same factors as the proprietary adjustment. This is the case at subsequent filing of the uncertainty of measurement at active proprietary adjustment.

6.2.2.1 Sensor Information → Common

This shows the general information of the connected sensor.
6.2.2.2 Sensor Information → Channels

These fields contain information of the respective measuring channel. Angle and speed cannot be selected simultaneously. If speed selected, power can be selected as an additional channel.

6.2.3 Measurement Adjust.

In this dialog box all measuring adjustments can be viewed and changed. The measurement adjustments are subdivided into measured variable, diagram, trigger and OK/NOK-evaluation. Except for the serial number, these adjustments will be accepted without confirmation.

The adjustments in Measured variable→Type, Measured variable→Sampling rate, Measured variable→Display and Measured variable→Diagram→Reducing the sampling rate by averaging via X values are sensor related data and are saved in the sensor. Herewith an automatic configuration of the software to the connected sensor is warranted.

When the application is finished, the previously not mentioned values are stored in the Windows registry under the logged in user and restored after a restart of the software.
6.2.3.1 Measurement Adjustments → Measured Variable → Type

This workspace is for the configuration of the measured variables which were recorded by DR-USB-VS. Torque can always be recorded, but angle of rotation and speed variables cannot be recorded at the same time.

The measurement adjustments are partitioned in measured variable, diagram and trigger. Before the adjustment it must be determined whether angle of rotation or speed (including mechanic performance) should be measured. This adjustment is selected accordingly in 'Measured variable → Type'.

The switch-over takes a short moment because the sensor gets configured via the interface. After the switch-over the control elements and their contents will accordingly be adopted in 'Measured variable → Display', 'Measured variable → Diagram' and in 'Measured variable → Trigger'.

**Caution:** The switch-over between angle of rotation and speed is only possible if a Lorenz USB sensor from the DR-3000-series has been connected. Otherwise, the control elements in 'Measured variable → Type' are deactivated.

6.2.3.2 Measure Adjust. → Measured Variable → Sample Rate

Following measuring/sampling rates are selectively adjustable: 2500/sec, 1250/sec, 1000/sec, 500/sec, 250/sec, 200/sec, 185/sec, 100/sec, 50/sec, 33/sec, 25/sec, 20/sec, 10/sec, 1/sec, 50/min, 20/min, 10/min, 1/min.

6.2.3.3 Measure Adjust. → Measured Variable → Display

The configuration display varies depending on the adjustment in 'Measured variable → Type' whether speed or angle of rotation is active.

The adjustments in 'Measured variable → Display' determine the output and display of the physical variables. Here, for each physical size the amount of positions after the decimal point, the unit, the moving average value and the leading sign can be configured. By the automatic configuration, depending on the read-out sensor data, the number of positions after the decimal point, the unit of the torque sensor and the unit of the mechanic performance (if active) can be adjusted.

Up to four positions after the decimal point can be displayed for each physical variable. This adjustment is being considered in the digital displays, in the diagram and the output of the CSV-file. German, English and American units are available for the determination of a physical variable unit. The conversion to the adjusted unit will be executed by the software automatically. A moving average can be established for any physical variable over 1 to 512 values with a gradation in raster $2^n$ of the adjusted measurement rate.

The leading sign of the physical variable is predefined in the sensor. By adjustment in 'Measure variable → Display → Sign' the leading sign can be changed.

6.2.3.4 Measure Adjust. → Diagram

In input box 'Reducing the sampling rate by averaging via X values.' it is possible to decrease the measuring points which should be saved by entering a value for X. Hence, the adjusted sampling rate e.g. 200/sec at X=10 will be reduced to 20 measured values in a file. When reducing the sampling rate, an averaging over the last X values is carried out.
The adjustment ‘Reducing the sampling rate by averaging via X values.’ Has no effect on the illustrated values in the digital displays.

The adjustments under 6.2.3.3 Measure Adjust. → Measured Variable → Display → Average of the individual physical sizes and the adjustment ‘Reducing the sampling rate by averaging via X values.’ act cumulatively.

The adjustment of this configuration should be started with the X-axis. Here, it can be selected to record the measured values via time/, torque/, angle/, speed or the mechanic performance. Resulting from the adjustment of the X-axis, the application updates the number of Y-axis as well as their selectable contents. All combinations of measuring variables can be illustrated in a diagram.

Caution: The measured values are written in a CSV-file with the physical variables which were adjusted here. The writing sequence is: [X-axis], [Y1-Achse], [Y2-axis], [Y3-axis]. If a Y-axis is not required, it is also possible to set them “Off”. Nevertheless, the application assures that minimum one variable on the Y-axis has not been set “Off”.

E-Mail: info@lorenz-sensors.com
Internet: www.lorenz-sensors.com
6.2.3.5 Measure Adjust. ➞ Trigger

Course:
1. Select a start event.
2. Select a stop event.
3. Enter trigger key.
4. Actuate a trigger start event.
5. Actuate a trigger stop event.

Initial state
- Measure OFF
- Trigger OFF
- Trigger grey

Trigger pressed?
- No
- Yes

Measure OFF
- Trigger ON
- Trigger yellow flash

Triggerstart event fulfilled?
- No
- Yes

Measure ON
- Trigger ON
- Trigger green

Triggerstop event fulfilled?
- No
- Yes
In the previous signal flowchart, the general course of measurement by means of a triggering is described. The activation button ‘Trigger’ can be found in the ‘Meas./Diagram Mode’ underneath ‘Measure Stop’. The software triggering consists of two events which are adjustable according the requirements:

**Triggerstart → Source:**
- **Off/Measure Start:**
  - Entering ‘Measure Start’ releases the triggerstart event. (This function to start an event can also be entered in the following sources).
  
- **Torque(M)/ Angle(α)/ Speed(n)/ Performance(P):**
  - See chapter 6.2.3.5.1 Triggering to a Physical Variable ( M, α, n, P ).

- **Systemtime:**
  - The application shows an input box where the date and the time of the measurement start can be adjusted. The adjustment is limited to the current time plus 15 seconds. These values must be re-adjusted after each measurement; otherwise the following measurement will start immediately by pressing the trigger, because the previously adjusted time lies in the past.

- **Start delay:**
  - After the trigger-start-event, the start of the measurement series can be delayed by the specified time (postrigger). Allowable values are 0ms (no delay), 20ms – 5000ms.

- **After executing Start/Stop:** through these fields, actions can be assigned to both trigger events.
  - After the event, evaluation and storage actions, the program specified in this field will be executed.
  - Any executable files and batch files are admissible. These files can be manually specified with full path or selected via requester through the folder icon.

**Remark:** The source adjustments of trigger start and trigger stop can be optionally combined with each other.

**Remark:** The adjustments “Measurement duration” and “Number of measurements” refer to the adjusted sampling rate and not to the reduction of the sampling rate.
6.2.3.5.1 Triggering to a Physical Variable (M, α, n, P)

The picture on the following page shows an example of how a measurement by means of triggering can be recorded to a physical variable. At this triggering not only the value of threshold (Y_{over}, Z_{over}) of a physical variable, but also a direction must be indicated. In the example diagram, the direction 'over run' is triggered. This means that the measured value must fall below the hysteresis value before the trigger will react to the over run of the value of threshold. On the opposite, the adjustment 'under run' means that the measured value must exceed the hysteresis value before the trigger reacts to the under run of the value of threshold. The grey-framed area of the example diagram equals the display in the diagram of the DR-USB-VS after the measurement course. This area can be stored in a CSV-file.

- Y_{over} = Triggerstart value of a physical variable with directional adjustment 'over run'
- Z_{over} = Triggerstop value of a physical variable with directional adjustment 'under run'

At over run, the value of the hysteresis is deducted from the value of threshold; when below, it will be added. The calculation of hysteresis for each possible physical variable is shown beneath the example diagram on the next page.

6.2.3.5.2 Diagram Example

6.2.3.5.3 Calculation of Hysteresis

\[
M_{Hysteresis} = M_{Meas range f.s.} \cdot 0.01 \cdot K_{M_{usd}} \\
\alpha_{Hysteresis} = 32 \cdot K_{\alpha_{usd}} \\
n_{Hysteresis} = 20 \cdot K_{n_{usd}} \\
P_{Hysteresis} = \frac{M_{Meas range f.s.} \cdot 2\Pi \cdot 50 \cdot K_{P_{usd}}}{60} \approx M_{Meas range f.s.} \cdot 5.236 \cdot K_{P_{usd}}
\]

Imperative is \[\{M_{Meas range f.s.} \cdot N \cdot m\}\]
Constant-tables which are necessary for the calculation of the hysteresis. Use the respective unit factor of the physical variable which you have adjusted in the application.

<table>
<thead>
<tr>
<th>Adjustment</th>
<th>( K_{M_{i,s}} )</th>
<th>Adjustment</th>
<th>( K_{n_{i,s}} )</th>
<th>Adjustment</th>
<th>( K_{T_{i,s}} )</th>
</tr>
</thead>
<tbody>
<tr>
<td>kN\cdot m</td>
<td>0,00100000</td>
<td>1/min</td>
<td>1,00000000</td>
<td>MW</td>
<td>0,00001000</td>
</tr>
<tr>
<td>N\cdot m</td>
<td>1,00000000</td>
<td>rad/min</td>
<td>6,28318531</td>
<td>kW</td>
<td>0,00100000</td>
</tr>
<tr>
<td>N\cdot cm</td>
<td>100,00000000</td>
<td>1/s</td>
<td>0,01666667</td>
<td>W</td>
<td>1,00000000</td>
</tr>
<tr>
<td>N\cdot mm</td>
<td>1000,00000000</td>
<td>rad/s</td>
<td>0,10471976</td>
<td>hp</td>
<td>0,00134102</td>
</tr>
<tr>
<td>ozf\cdot ft</td>
<td>11,80099400</td>
<td>rpm</td>
<td>1,00000000</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ozf\cdot in</td>
<td>141,61193000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>lbf\cdot ft</td>
<td>0,73756210</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>lbf\cdot in</td>
<td>8,85074580</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Adjustment</th>
<th>( K_{\alpha_{i,s}} )</th>
</tr>
</thead>
<tbody>
<tr>
<td>°</td>
<td>0,25000000</td>
</tr>
<tr>
<td>rad</td>
<td>0,00436332</td>
</tr>
</tbody>
</table>

### 6.2.3.6 Measurement Adjustments → OK/NOK Evaluation

These settings affect the evaluation of a measurement series. After a trigger stop event occurs, the max. values of these measurement series are determined and compared with the stored limits. In order to obtain an OK-display, the max. value of a measurement series must be above the lower and below the upper limit. If two conditions are defined, both conditions must meet the OK criteria for a total OK-display.
6.2.4 Documentation

Here, the user can carry out documentation configuration. The adjustments refer to the storage of measurements as BMP and/or CSV-file as soon as printing the diagram.
6.2.4.1 Documentation → Output Measured Values

- **Automatic Storage:**
  The storage of the measured value into an output file can occur automatically by the software. Three adjustment possibilities are selectable for this:
  - **None:** The automatic storage is disabled.
  - **Save all measurements into one file:** This option files each measurement in the same CSV-file at the end. The name from field prefix is used as the file name. The file gets stored in the registered target directory.
  - **Save each measurement with an own index:** This option creates a separate CSV-file at the end of each measurement. The file name consists of the prefix and the index YYYYMMDDHHmmss#### (‘####’ number beginning with leading zeros 0000; 0001; ...)

  The path length is limited by the running system.

  **Remark:** Definition “Measurement” see chapter 6.1.1 File → Save Measvalue (Shortcut ‘Ctrl+M’).

- **Target Directory:**
  The target path is registered under ‘Target directory’ (Standard adjustment ..\<user name>\My documents\DR-USB-VS). Instead of this, you can click on the folder and select a directory.

- **Prefix:**
  Please enter the file name which is used for the automatic storage in this input box. (Further details about file name/prefix can be found under headline “Automatic Storage”.

6.2.4.2 Documentation → Output diagram

**Automatic Storage:**

The software can automatically store the diagram in an output file. For this, two adjustment possibilities can be selected:
  - **None:** the automatic storage is disabled.
  - **Save any diagram with an own index:** this option creates a separate BMP-file at the end of each measurement. The file name is a combination of the prefix and the index YYYYMMTTHHmmsss#### (‘####’ number beginning with leading zeros 0000; 0001; ...).

  The path length is limited by the running system.

  **Remark:** Definition “Measurement” see chapter 6.1.2 File → Save Diagram (Shortcut ‘Ctrl+D’).

- **Target Directory:**
  The target path is registered in ‘Target directory’ (standard adjustment ..\<user name>\My documents\DR-USB-VS). Instead of this, you can click on the folder and select a directory.

- **Prefix:**
  Enter the file name which shall be used for the automatic storage in this input box (further details regarding file name/prefix can be found under headline ‘Automatic Storage’).

- **Memory Size:**
  See chapter 6.1.2 File → Save Diagram ‘max’, ‘normal’, ‘min’ and ‘window’.
6.2.4.3 Common Settings Output Values and Output OK/NOK-Evaluation

- **End of line character:**
  The desired line ending mark for the output in a file gets adjusted in this box.
  Following possibilities can be selected:
  - **CRLF**: Carriage Return / Line Feed Carriage return line feed (MS-DOS, Windows)
  - **LFCR**: Line Feed / Carriage Return Line feed carriage return (Linux Console)
  - **CR**: Carriage Return Carriage return (Apple II, Apple Mac OS up to Version 9)
  - **LF**: Line Feed Line feed (Unix-Derivate, Mac OS X)

- **Column separator:**
  The column delimiter will be read out at the first execution of the application from Windows system control (country selection) and will be set accordingly. At each further restart of the application, the previously adjusted delimiter will be used. Following selection is possible in this box:
  - **TAB**: Tabulator
  - **;**: Semicolon
  - **,**: Comma
  - **.**: Point
  - **Space**: Space character

- **Decimal separator:**
  The decimal delimiter is carried out the same way as described for the column separator. Following selection is possible in this box:
  - **,**: Comma
  - **.**: Point

- **Remark:** Supplementary changes of the country adjustments in the operating system have no influence on the once adjusted values of this software.

- **Additional information show / hide:**
  In this group, checkmarks can be placed to add further information to the output of measured values. The entries in the three entry boxes ‘Headline’, ‘Address’ and ‘Comment’ can be specified arbitrarily. With the checkmark, these entries will be recorded in the output file. The ‘Uncertainty of measurement’ - if the connected sensor has one - can also be displayed in the output file. By a checkmark in ‘Date / Time’ the measurement period can also be recorded in the output file. By a checkmark in ‘Physical unit’ it is also possible to systematically fade in/out the physical units in the output file.

6.2.4.4 Documentation → Additional information

Here, the free text can be found which can be activated in 'Documentation → Output measured values → Additional information show / hide'.
6.2.5 Sensor Adjustment

In this dialog, a user adjustment of torque can be executed or deleted. Furthermore, the uncertainty of measurement in % can be stored in the connected sensor. This variable - if available - shows the application in the measurement / diagram mode and in the sensor information. The uncertainty of measurement can also be read out in a CSV output file (see chapter 6.2.4.1 Documentation → Output Measured Values)

- **Run User’s Adjustment:**
  With this function, a two-point adjustment of torque can be carried out. In order to read the first point, the sensor must be completely unloaded, so that the application can detect the zero point of the sensor and the control amplification factor. Now indicate the desired load of the sensor for the second measuring point. The indication must be in the range of [final value of measurement 1,3 > adjustment value > final value of measurement / 2], otherwise the adjustment cannot be continued. The closer the adjustment value to the final value of measurement, the more precisely the adjustment will be! If the user adjustment has been completed successfully, it can be seen in the sensor information. Herewith, the user adjustment is active and the proprietary adjustment is inactive. This procedure can be cancelled by deletion of the user adjustment. Then, the proprietary adjustment is reactivated.
- **Delete User’s Adjustment:**
  This function irrevocably deletes the user adjustment and activates the proprietary adjustment. The uncertainty of measurement of the user adjustment is also deleted.

- **Store Uncertainty of Measurement in the Sensor:**
  This function allows to store a maximum value for the uncertainty of measurement in the sensor. This value is usually determined at a proprietary or DKD calibration. If the proprietary adjustment of the connected sensor is active and if a value for the uncertainty of measurement was indicated, it means that the sensor had a proprietary or a DKD calibration at Lorenz Messtechnik GmbH. Permissible values for the uncertainty of measurement are [5 % > uncertainty of measurement > 0 %]. If the sensor is connected, this value will be displayed in the ‘Meas./Diagram Mode’, in the ‘Sensor Information’ and if required in the CSV-output file. This value has no influence on the measured values.

6.3 **Meas./Diagram Mode**

In the ‘Meas./Diagram Mode’ the digital displays of the physical variables and the diagram can be activated. Only the displays which were check-marked in ‘Measure Adjust. → Measured variable → Type’ are active. At measuring angle this equates to torque and angle of rotation and at measuring speed it equates to torque, speed and performance. The function which sets the ‘Angle = 0’ and the adjustment ‘Set angle to zero at measure start / triggerstart-event’ is only active at the angle of rotation measurement (see above chart - right angle of rotation measurement with left speed measurement).
Each, the digital displays and the diagram are in a discrete window. These windows can be positioned to the main window or it can freely be placed on the monitor. In order to scroll the windows, the mouse pointer must be placed on the title bar of the respective window. By keeping the left mouse key pressed, the window can be shifted or positioned. The contents of the window automatically adopts to the window size. By key ‘Ctrl’ the positioning in the main window can be avoided.

Each digital display has four output fields. One each for the current measured value, the tared value, the minimum value and the maximum value. The minimum and maximum value can be set back by the buttons ‘MIN Reset’ and ‘MAX Reset’. If the tare-button shows ‘TARE’ and is kept pressed, this will set the current measured value to zero and the tared difference will be displayed above in the output field. Afterwards this button indicates ‘TARA=0’, thus the tare can be cancelled.

The OK/NOK display always shows the total of all defined criteria. If the criteria is met, a green indicator appears. If at least one criterion is not met, the indicator turns red. A grey indicator means that there is currently no evaluation, e.g. after start-up or after a new series of measurements was started.

Measure Start:
By this button, a measurement gets started. The digital displays and the diagram will be fed with measured values after pressing this button. Unnecessary buttons are deactivated during the measurement. In addition, the status of the application “Measuring…” is indicated in the status bar.

Software trigger start event

Measure Stop:
Can only be used at active measurement. As soon as the button was pressed the measuring will be stopped and will initiate possible automatic storage (see chapter 6.2.4 Documentation). At active automatic storage into a file, the progress is shown on the status bar as well as the idle state ‘Ready for use. Sensor connected’.

Software trigger stop event

Trigger:
This button activates a software triggering as explained in chapter 6.2.3.5.1 Triggering to a Physical Variable ( M, α, n, P ). The status lamp on the side of the button blinks yellow at active triggering. By pressing again, the triggering will be deactivated. The course of a software trigger is described in chapter 6.2.3.5 Measure Adjust. ➔ Trigger.

<table>
<thead>
<tr>
<th>Trigger LED</th>
<th>Condition</th>
</tr>
</thead>
<tbody>
<tr>
<td>grey</td>
<td>Trigger OFF</td>
</tr>
<tr>
<td>flashing</td>
<td>Trigger waits for a trigger start event. Only the digital displays are updated.</td>
</tr>
<tr>
<td>yellow</td>
<td>Trigger Measurement ON. Digital displays and diagram are updated with values.</td>
</tr>
<tr>
<td>green</td>
<td></td>
</tr>
</tbody>
</table>

Trigger Auto Repeat:
By a check mark, the trigger gets reactivated as soon as all actions of the Trigger-Stop-Event are processed (e.g. write file. See chapter 6.2.4.1 Documentation ➔ Output Measured Values and chapter 6.2.4.2 Documentation ➔ Output diagram)

Activate only if an automatic storage from 0 or 6.2.4.2 is active.

Single Measurement:
By this key, a single current measured value gets requested from the active sensor. This function can only be carried out in the idle mode of the application.

‘Control’ and ‘Angle = 0’:
The buttons ‘Control’ and ‘Angle = 0’ are only activated during the measurement at low sampling rates (<20/sec) and in idle mode.
By means of the control, the measuring bridge in the sensor gets detuned and issues the nominal range. A red lamp next to the button indicates active control. By clicking on ‘Control’ again, it will be deactivated. By means of the ‘Angle = 0’ button the angle value will be set to zero. This button is only visible during an angle of rotation measurement.

**Set Angle to Zero at Measure Start / Triggerstart-Event:**
The user can place a checkmark here, so that at the start of a measurement through ‘Trigger’ or ‘Measure Start’, the application automatically sets the angle value to zero. This button is only visible during an angle of rotation measurement.

7 **Parameter sets**
The settings in the software, which are made in the registers measuring settings, measurement and diagram mode as well as documentation, can be combined and saved into a parameter set. In the software, 20 memory spaces are available for parameter sets, which can be switched quickly. All parameter sets can be imported or exported to a text file.

7.1 **Save Parameter set**
- Open the “Parameter sets” dialog via the button of register “Measurement settings”, “Documentation” or “Measurement and Diagram mode”.
- Select a memory space in “Designation”. Free memory spaces are indicated by “-”. If an occupied memory space is selected, it will be overwritten with the current values.
- Enter a name and confirm with OK.
- Accept the protection question.
  
  **Caution:** The current settings are irretrievably overwritten with the contents of the selected memory space!
- Exit the “Parameter sets” dialog.

7.2 **Use Parameter set**
- Open the “Parameter sets” dialog via the button of register “Measurement settings”, “Documentation” or “Measurement and Diagram mode”.
- Select a memory space in “Name”. Free memory spaces are indicated by “-” and can’t be used.
- Accept the protection question.
  
  **Caution:** The current settings are irretrievably overwritten with the contents of the selected memory space!
- Exit the “Parameter sets” dialog.

7.3 **Delete Parameter set**
- Open the “Parameter sets” dialog via the button of register “Measurement settings”, “Documentation” or “Measurement and Diagram mode”.
- Select a memory space in “Name”. Free memory spaces are indicated by “-”.
- Accept the protection question.
  
  **Caution:** The content of the memory space is irretrievably deleted!
- Exit the “Parameter sets” dialog.

7.4 **Export all Parameter sets**
- Open the “Parameter sets” dialog via the button of register “Measurement settings”, “Documentation” or “Measurement and Diagram mode”.
- Select a directory into which the parameter records are to be exported. A file “ParameterSets.txt” is created during the export.
  
  **Caution:** If a file "ParameterSets.txt" exists in the selected directory, it will be overwritten!
- Exit the “Parameter sets” dialog.
7.5 Import all Parameter sets

- Open the “Parameter sets” dialog via the button of register “Measurement settings”, “Documentation” or “Measurement and Diagram mode”.
- Select a directory from which the “ParameterSets.txt” file shall be imported.
  
  **Caution:** All parameter sets stored in the software are overwritten with the file "Parameters.txt" from the selected directory!
- Exit the “Parameter sets” dialog.

8 User Data

A memory space is reserved on the sensors, which can be written and read as desired. This memory is divided into 8 blocks, each with 32 bytes. In the “User data” tab, these blocks can be written or read out. For each block, it is possible to individually select whether the representation takes place byte-wise in hexadecimal, or in ASCII as a character string with 32 characters. This selection is retained at the next program start.

**Hex-Representation:**
Each value is represented hexadecimal in the value range 00 to FF.

**ASCII-Representation:**
Characters of the standard 8-bit ASCII set according Microsoft are displayed
Non-printable characters are displayed as “\".
If less than 32 characters are entered, the remaining characters are filled with zero bytes.

When changing displaying between hexadecimal and ASCII, the contents of the data blocks are not changed.

  **Caution:** The number of writing operations in the sensors may be limited. Please observe the operating instruction of the respective sensor!
9 Debugging

This chart helps to find frequent errors and the measures for debugging:

<table>
<thead>
<tr>
<th>Error</th>
<th>Possible Cause</th>
<th>Debugging</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application does not start or does not find any a sensor</td>
<td>Operating system too old</td>
<td>Required operating system: WIN VISTA, WIN 7, 8, 8.1, 10</td>
</tr>
<tr>
<td></td>
<td>No drivers for USB sensors</td>
<td>Install the driver packet from the product CD. Install drivers with administrator rights, only.</td>
</tr>
<tr>
<td></td>
<td>Sensor is not connected to the PC</td>
<td>Connect sensor to the PC</td>
</tr>
<tr>
<td></td>
<td>A newer version of the software run on this PC before</td>
<td>Always use the newest version of this software</td>
</tr>
<tr>
<td></td>
<td>USB Hub has less power</td>
<td>Take care your USB port delivers enough power. Do not use passive USB hubs.</td>
</tr>
<tr>
<td></td>
<td>Sensor is not compatible</td>
<td>Always use compatible software</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Error</th>
<th>Possible Cause</th>
<th>Debugging</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software hangs or crashes during start-up</td>
<td>Incompatible drivers of third-party products</td>
<td>Try de-activating modems in the device manager. Manually change the com port number of Lorenz Com port in the device manager.</td>
</tr>
</tbody>
</table>

10 Continuative Documents

Following documents contain reference information about the DR-USB-VS:

**Software manuals:**

**Sensor manuals:**
- Document number 090307, „Operation Manual for ’Plug and Play’ USB Torque Sensor. For The Type DR-3000“ (German. 090303).
- Document number 090322, „Operation Manual for ’Plug and Play’ USB Torque Sensor. For The Types DR-3001 and DR-3003“ (German. 090321).

**Sensor data sheets:**
- Document number 080713, Data sheet „USB - Torque Sensor with Configuration and Evaluation Software“ for the types DR-3000 and DR-3000P (German. 080697).
- Document number 080739, Data sheet „USB - Torque Sensor with Configuration and Evaluation Software” for the type 3001 (German. 080737).
- Document number 080740, Data sheet „USB - Torque Sensor with Configuration and Evaluation Software” for the type 3003 (German. 080738).

**Manuals for Developers:**
- Document number 090110, Lorenz protocol „a flexible command set for digital sensors and interfaces“.